Survey Share Errors for EU Accounts
Incident Report for SurveyGizmo
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 25, 2018 - 15:29 UTC
Update
We are continuing to investigate this issue.
Posted 10 months ago. Nov 25, 2018 - 15:28 UTC
Investigating
Errors are occurring on survey share tabs based on accounts on the EU service. Our engineers are investigating currently to find and fix the source of the problem. Please click the subscribe button to receive further updates as we work to resolve this issue as soon as possible.
Posted 10 months ago. Nov 25, 2018 - 15:16 UTC
This incident affected: SurveyGizmo Application - EU.